Back to overview
Degraded
Certain payment methods temporarily unavailable
Apr 1, 2026 at 8:05am UTC
Affected services
Homepage
Updated
Apr 1, 2026 at 8:23am UTC
We are working with Paddle to resolve the issue and will provide another update once these payment options have been restored.
Affected services
Created
Apr 1, 2026 at 8:05am UTC
Payment methods processed through Paddle are temporarily unavailable in the checkout dialog following recent domain migration changes. This currently affects PayPal and local payment methods. Card payments remain available.
Affected services