Back to overview
Downtime
Blog unavailable
Apr 9, 2026 at 6:48am UTC
Affected services
Blog
Resolved
Apr 9, 2026 at 10:36am UTC
Blog.baidudl.com is back online. The outage was caused by an internal service failure that prevented the web server from restarting correctly. No data was affected. We've applied a fix to prevent this from happening again.
Affected services
Created
Apr 9, 2026 at 6:48am UTC
We are aware that blog.baidudl.com is currently unavailable and are looking into it. Downloads and your account are not affected. We'll update this shortly.
Affected services